June 6, 2007

Upgrading to Flash 9 in OpenSuse 10.2

opensuse.gifBy default OpenSuse currently comes with Flash version 7, which works for much of the interweb, but not all of it. Increasingly video websites and other neato stuff like Google Maps Street View require Flash 9. In order to install Flash 9 in OpenSuse:

Go to http://www.adobe.com/go/getflashplayer

The site will know you're running linux and present you with the appropriate installers. DO NOT download the .tar.gz. It will not work.

Instead right click on the .rpm and select "Save Link As...". Save the RPM somewhere in your home folder, like your desktop.

Go find the file. If you're running Gnome, right click on the file and select "Open with Install Software".

You'll be prompted for your root password. Enter it.

The Software installer app will soon present you with a list of packages to install with only one item. Flash Player 9. Click on Install.

When it's done, restart your browser and browse on over to http://www.adobe.com/shockwave/welcome/ to see if it worked. There should be a test flash object embedded in the page. Click on about to see your current flash version.

Posted by stoltenow at June 6, 2007 3:56 AM

Comments

Post a comment




Remember Me?